Google+ Now Available For iPhone Owners, Requires iOS 4.0 Or Later

Share And Comment

Good news for iPhone owners who love Google+ (Plus). The application is now available in the AppStore for the iPhone 4, iPhone 3GS, and iPhone 3G. Additionally, the application requires that iOS 4.0 or later be installed. Unfortunuately, the Google+ plus application is not yet available for the iPod or iPad. No reason was given why, so we hope in the coming days that’s made available to those users.

For more information and to download the application, visit http://itunes.apple.com.

Share And Comment